您的位置:首页 > 其它

Bzoj 1619 [Usaco2008 Nov]Guarding the Farm 保卫牧场

2015-10-08 19:29 375 查看

Description

The farm has many hills upon which Farmer John would like to place guards to ensure the safety of his valuable milk-cows. He wonders how many guards he will need if he wishes to put one on top of each hill. He has a map supplied as a matrix of integers; the matrix has N (1 < N <= 700) rows and M (1 < M <= 700) columns. Each member of the matrix is an altitude H_ij (0 <= H_ij <= 10,000). Help him determine the number of hilltops on the map. A hilltop is one or more adjacent matrix elements of the same value surrounded exclusively by either the edge of the map or elements with a lower (smaller) altitude. Two different elements are adjacent if the magnitude of difference in their X coordinates is no greater than 1 and the magnitude of differences in their Y coordinates is also no greater than 1.

农夫JOHN的农夫上有很多小山丘,他想要在那里布置一些保镖(……)去保卫他的那些相当值钱的奶牛们。 他想知道如果在一座小山丘上布置一名保镖的话,他总共需要招聘多少名保镖。他现在手头有一个用数字矩阵来表示地形的地图。这个矩阵有N行(1 < N < = 100)和M列( 1 < M < = 70) 。矩阵中的每个元素都有一个值H_ij(0 < = H_ij < =10,000)来表示该地区的海拔高度。请你帮助他统计出地图上到底有多少个小山丘。 小山丘的定义是:若地图中一个元素所邻接的所有元素都比这个元素高度要小(或它邻接的是地图的边界),则该元素和其周围所有按照这样顺序排列的元素的集合称为一个小山丘。这里邻接的意义是:若一个元素与另一个横坐标纵坐标和它的横纵坐标相差不超过1,则称这两个元素邻接。 问题名称:guard 输入格式: 第一行:两个由空格隔开的整数N和M 第二行到第N+1行:第I+1行描述了地图上的第I行,有M个由空格隔开的整数:H_ij.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 describes row i of the matrix with M space-separated integers: H_ij

Output

Line 1: A single integer that specifies the number of hilltops

Sample Input

8 7
4 3 2 2 1 0 1
3 3 3 2 1 0 1
2 2 2 2 1 0 0
2 1 1 1 1 0 0
1 1 0 0 0 1 0
0 0 0 1 1 1 0
0 1 2 2 1 1 0


0 1 1 1 2 1 0

Sample Output

3


HINT

三个山丘分别是:左上角的高度为4的方格,右上角的高度为1的方格,还有最后一行中高度为2的方格.

Key To Problem

算是比较水的bfs吧,还是直接看代码好了

Code

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define N 710
using namespace std;
struct node
{
int x,y,s;
};
node Edge[N*N];
int n,m,tot;
int map

;
bool used

;
int dir[8][2]={
0,1,
1,0,
-1,0,
0,-1,
1,-1,
-1,1,
-1,-1,
1,1
};

bool cmp(node a,node b)
{
return a.s>b.s;
}

bool is(int x,int y)
{
if(x<=0||x>n||y<=0||y>m)
return 1;
return 0;
}

void bfs(node u)
{
used[u.x][u.y]=true;
queue<node>Q;
Q.push(u);
while(!Q.empty())
{
node k=Q.front();
Q.pop();
for(int i=0;i<8;i++)
{
int xx=dir[i][0]+k.x;
int yy=dir[i][1]+k.y;
if(!map[xx][yy]||used[xx][yy]||is(xx,yy))
continue;
if(map[xx][yy]>map[k.x][k.y])
continue;
used[xx][yy]=true;
node p;
p.x=xx,p.y=yy;
Q.push(p);
}
}
}

int main()
{
cin>>n>>m;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
scanf("%d",&map[i][j]);
tot++;
Edge[tot].x=i,Edge[tot].y=j,Edge[tot].s=map[i][j];
}
}
sort(Edge+1,Edge+tot+1,cmp);
int ans=0;
for(int i=1;i<=n*m;i++)
{
node k=Edge[i];
if(!map[k.x][k.y]) break;
if(!used[k.x][k.y])
bfs(k),ans++;
}
cout<<ans<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bzoj 搜索