您的位置:首页 > 理论基础 > 数据结构算法

Who's in the Middle

2015-10-08 15:45 323 查看
D - Who's in the Middle
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2388

Appoint description: 
System Crawler  (2015-10-06)

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5


Sample Output

3


Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.

一开始还以为要去重,所以Wa了一次,结果试一下不去重结果就A了。这题题目都没看懂,就看了看Hint没想到被我猜对了。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
#define T 10005
#define inf 0x3f3f3f3f
#define CRL(a) memset(a,inf,sizeof(a))
typedef long long ll;
int main()
{
/*freopen("input.txt","r",stdin);*/
int a[T];
int n,i,j,k;
while(~scanf("%d",&n))
{
for(i=0;i<n;++i){
scanf("%d",&a[i]);
}
sort(a,a+n);k=n;
printf("%d\n",a[k/2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 数据结构