您的位置:首页 > 其它

hdu 1061 Rightmost Digit

2015-10-08 15:09 393 查看
Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4


Sample Output

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.


以4为循环

#include <stdio.h>

int main()
{
int a[10][4]={
0,0,0,0,
1,1,1,1,
6,2,4,8,
1,3,9,7,
6,4,6,4,
5,5,5,5,
6,6,6,6,
1,7,9,3,
6,8,4,2,
1,9,1,9};
int n,t;

scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
printf("%d\n",a[n%10][n%4]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: