您的位置:首页 > 其它

POJ - 3684 Physics Experiment(弹性碰撞)

2015-10-08 01:11 417 查看
Physics Experiment

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u
Submit Status

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters
above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it
will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).


Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers N, H,R, T.

1≤ N ≤ 100.

1≤ H ≤ 10000

1≤ R ≤ 100

1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100


Sample Output

4.95
4.95 10.20


题意:用N个半径为R厘米的求进行实验。在H米高的位置设置一个圆筒,将球垂直放入(从下向上数第i个球的底端距离地面高度为H+2R*(i-1)),从最下面的球开始掉落,此后每一秒又有一个球开始掉落。发生的碰撞都是弹性碰撞,求开始T秒后每个球底端的高度,g=10m/s^2。
分析:球发生弹性碰撞可以看做是相互穿过继续运动,由于球的顺序不会发生改变,我们按每个球都是正常的自由落体运动来计算,最后排序就能得到答案,对第i个球需要在计算结果上再加上2Ri。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

const double g = 10.0;

int N, H, R, T;

double y[110];

double calc(int T)
{
if (T < 0) return H;
double t = sqrt(2 * H / g);
int k = (int)(T / t);
if (k % 2 == 0)
{
double d = T - k*t;
return H - g*d*d / 2;
}
else
{
double d = k*t + t - T;
return H - g*d*d / 2;
}
}

int main()
{
int casen;
scanf("%d", &casen);
while (casen--)
{
scanf("%d%d%d%d", &N, &H, &R, &T);
for (int i = 0; i < N; i++)
y[i] = calc(T - i);

sort(y, y + N);

for (int i = 0; i < N; i++)
{
if (i) printf(" ");
printf("%.2f", y[i]+i*R*2/100.0);
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 弹性碰撞