您的位置:首页 > 运维架构

UVA_679: Dropping Balls

2015-10-07 21:14 225 查看

Description

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree,
or follows the path of theright subtree, until it stops at one of the leaf nodes of FBT. To determine aball's moving direction a flag is set up in every non-terminal node with twovalues, either
false or true. Initially, all of the flags arefalse. When visiting a non-terminal node if the flag's current value atthis node is
false, then the ball will first switch this flag's value,i.e., from the
false to the true, and then follow the left subtreeof this node to keep moving down. Otherwise, it will also switch this flag'svalue, i.e., from the
true to the false, but will follow the rightsubtree of this node to keep moving down. Furthermore, all nodes of FBT aresequentially numbered, starting at 1 with nodes on depth 1, and then those ondepth 2, and so on. Nodes on
any depth are numbered from left to right.

For example, Fig. 1 represents a fully binary tree of maximum depth 4 withthe node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set tobe
false, the first ball being dropped will switch flag's values at node1, node 2, and node 4 before it finally stops at position 8. The second ballbeing dropped will switch flag's values at node 1, node 3, and node 6, andstop at position 12.
Obviously, the third ball being dropped will switchflag's values at node 1, node 2, and node 5 before it stops at position 10.



Fig. 1: An example of FBT with the maximum depth 4 and sequentialnode numbers.

Now consider a number of test cases where two values will be given for each test. Thefirst value is
D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of
I will notexceed the total number of leaf nodes for the given FBT. Please write a program to determine the stop position
P foreach test case.

For each test cases the range of two parameters D and I is as below:



Input

Contains l+2 lines.
Line 1 		 I the number of test cases
Line 2


test case #1, two decimal numbers that are separatedby one blank
...
Line k+1


test case #k
Line l+1


test case #l
Line l+2 -1 		 a constant -1 representing the end of the input file


Output

Contains l lines.
Line 1 		 the stop position P for the test case #1
...
Line k the stop position P for the test case #k
...
Line l the stop position P for the test case #l


Sample Input

5
4 2
3 4
10 1
2 2
8 128
-1


Sample Output

12
7
512
3
255


分析:对于一个节点k,其左子结点、右子结点的编号分别是2k和2k+1。每个小球都会落在根结点上,因此前两个小球必然是一个在左子树,一个在右子树。所以只需看小球的奇偶性就能知道最终落在哪颗子树中。当I是奇数时,它是往左的第(I+1)/2个小球;当I 是偶数时,它是往右走的第I/2个小球。这样,可以直接模拟最后一个小球的路线。

#include <cstdio>

int main()
{
int n;
int D,I;
scanf("%d",&n);
for(int t=0; t<n; t++)
{
scanf("%d%d",&D,&I);
int k = 1;
for(int i=0; i<D-1; i++)
if(I%2){k=k*2;I=(I+1)/2;}
else {k=k*2+1; I/=2;}
printf("%d\n",k);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: