您的位置:首页 > 其它

poj2420A Star not a Tree?【模拟退火】

2015-10-07 01:40 453 查看
Language:
Default

A Star not a Tree?

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4664 Accepted: 2276
Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete
problem in order to minimize the total cable length. 

Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects
several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers
to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable
forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.
Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.
Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.
Sample Input
4
0 0
0 10000
10000 10000
10000 0

Sample Output
28284


题意:给定一个平面和平面上n个点求出一点到所有点的距离和最小输出该最小距离;

解题思路:同poj1379模拟退火;

#include<cstdio>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#define eps 1e-3
#define inf 0x3f3f3f3f
#define PI acos(-1.0)
using namespace std;
const int NUM=30;
double dist(double x1,double y1,double x2,double y2){
return sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
}
double MAX(double a,double b){
return a>b?a:b;
}
double MIN(double a,double b){
return a<b?a:b;
}
struct point{
double x,y;
}A[110],B[110];
double d[110];
int X=10000,Y=10000;
int main()
{
int n,i,j,k;
srand((unsigned)time(NULL));
while(scanf("%d",&n)!=EOF){
for(i=0;i<n;++i){
scanf("%lf%lf",&A[i].x,&A[i].y);
}
for(i=0;i<NUM;++i){
B[i].x=double(rand()%10000+1);
B[i].y=double(rand()%10000+1);
d[i]=0;
for(j=0;j<n;++j){
d[i]+=dist(B[i].x,B[i].y,A[j].x,A[j].y);
}
}
double dmax=sqrt(1.0*(X*X+Y*Y));
while(dmax>eps){
for(i=0;i<NUM;++i){
double xx=B[i].x,yy=B[i].y;
for(j=0;j<NUM;++j){
double angle=double(rand()%10000+1)/10000.0*2.0*PI;
double mx=dmax*cos(angle);
double my=dmax*sin(angle);
double newx=xx+mx,newy=yy+my;
if(newx<eps||newx>X||newy<eps||newy>Y)continue;
double temp=0;
for(k=0;k<n;++k){
temp+=dist(newx,newy,A[k].x,A[k].y);
}
if(temp<d[i]){
d[i]=temp;B[i].x=newx;B[i].y=newy;
}
}
}
dmax*=0.8;
}
double ans=inf;
for(i=0;i<NUM;++i){
if(ans>d[i]){
ans=d[i];
}
}
printf("%.0lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj2420A Star not a