您的位置:首页 > 其它

1001. A+B Format (20)

2015-10-06 22:20 309 查看
Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

解题思路:

1,转化为字符串处理。

2,转化为%3部分和整除3的部分

[code]#include <iostream>
#include <string>
using namespace std;

int main(){

    int a, b;
    cin >> a >> b;
    int sum = a + b;

    if (sum < 0){
        cout << "-";
        sum = -sum;
    }

    char buffer[10];
    sprintf(buffer, "%d", sum);

    string s(buffer);
    int k = s.size() / 3;
    int k1 = s.size() % 3;
    for (int i = 0; i < k1; i++){
        cout << s[i];
    }
    if (k1 != 0){
        for (int j = k1; j < s.size(); j++){
            int n = j - k1;
            if (n % 3 == 0){
                cout << ",";
            }
            cout << s[j];
        }
    }
    else{
        for (int j = 0; j < s.size(); j++){
            int n = j ;
            if (n % 3 == 0){
                if (j != 0)
                    cout << ",";
            }
            cout << s[j];
        }
    }

}


第二种思路:

1,转化为字符串,然后从末位开始计数,逢3,push一个’,’,然后反向字符串,判断若反向后的字符串首字符为’,’,则不输出即可。

[code]#include <iostream>
#include <string>
using namespace std;

int main(){

    int a, b;
    cin >> a >> b;
    int sum = a + b;

    if (sum < 0){
        cout << "-";
        sum = -sum;
    }

    char buffer[10];
    sprintf(buffer, "%d", sum);

    string s(buffer);
    //cout << s << endl;

    string temp_s;

    for (int i = s.size() - 1; i >= 0; i--){
        temp_s.push_back(s[i]);
        int counter = s.size() - i;
        if (counter % 3 == 0){
            temp_s.push_back(',');
        }
    }
    for (int i = 0,j = temp_s.size() - 1; i < j; i++, j--){
        char c = temp_s[i];
        temp_s[i] = temp_s[j];
        temp_s[j] = c;
    }

    if (temp_s[0] != ','){
        cout << temp_s[0];
    }
    for (int i = 1; i < temp_s.size(); i++)
        cout << temp_s[i];

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: