您的位置:首页 > 其它

猴爬楼梯

2015-10-06 21:00 176 查看
Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10056 Accepted Submission(s): 5226

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58

97 93 23

84 62 64

33 83 27

0

Sample Output

Case 1: maximum height = 40

Case 2: maximum height = 21

Case 3: maximum height = 28

Case 4: maximum height = 342

最大上升子序列和

每块砖最多有180个状态,我对180个格子对X从小到大排序,X相等,Y就重小到大排序,那么这个问题就可以转换成类似求最大上升子序列问题一样思路的DP,DP[i]表示第i个格子时的最大值,dp[i+1]就是从前i个中找符合条件的最大的一个加上去。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node
{
int l,w,h;
}box[111];
int dp[111];
bool cmp(node a,node b)
{
if(a.l>b.l) return true;
if(a.l==b.l&&a.w>b.w) return true;
return false;
}
int main()
{
int d[3],n,i,j,c=1,k,sumh;
while(scanf("%d",&n)!=EOF&&n)
{
k=0;
for(i=0;i<n;i++)
{
scanf("%d%d%d",&d[0],&d[1],&d[2]);
sort(d,d+3);
//三种形态
box[k].l=d[2];box[k].w=d[1];box[k].h=d[0];k++;
box[k].l=d[2];box[k].w=d[0];box[k].h=d[1];k++;
box[k].l=d[1];box[k].w=d[0];box[k].h=d[2];k++;
}
sort(box,box+k,cmp);
for(i=0;i<k;i++) dp[i]=box[i].h;
for(i=k-2;i>=0;i--)
for(j=i+1;j<k;j++)
{
if(box[i].l>box[j].l&&box[i].w>box[j].w)//
if(dp[i]<dp[j]+box[i].h)
dp[i]=dp[j]+box[i].h;
}
sumh=dp[0];
for(i=0;i<k;i++)
if(sumh<dp[i]) sumh=dp[i];
printf("Case %d: maximum height = %d\n",c++,sumh);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: