您的位置:首页 > 其它

弱校联萌十一大决战之厉兵秣马H. Hanoi Towers poj3572

2015-10-06 11:05 429 查看
The “Hanoi Towers” puzzle consists of three pegs (that we will name A, B, and C) with n disks of different diameters stacked
onto the pegs. Initially all disks are stacked onto peg A with the smallest disk at the top and the largest one at the bottom, so that they form a conical shape on peg A.



A valid move in the puzzle is moving one disk from the top of one (source) peg to the top of the other (destination) peg, with a constraint that a disk can be placed only onto an empty destination peg or onto a
disk of a larger diameter. We denote a move with two capital letters — the first letter denotes the source disk, and the second letter denotes the destination disk. For example, AB is a move from disk A to disk B.
The puzzle is considered solved when all the disks are stacked onto either peg B (with pegs A and C empty) or onto peg C (with
pegs A and B empty). We will solve this puzzle with the following algorithm.
All six potential moves in the game (AB, AC, BA, BC, CA, and CB) are arranged into a list. The order of
moves in this list defines our strategy. We always make the first valid move from this list with an additional constraint that we never move the same disk twice in a row.
It can be proven that this algorithm always solves the puzzle. Your problem is to find the number of moves it takes for this algorithm to solve the puzzle using a given strategy.


Input

The input file contains two lines. The first line consists of a single integer number n (1 ≤ n ≤ 30) — the number of disks in the puzzle. The second line contains descriptions
of six moves separated by spaces — the strategy that is used to solve the puzzle.


Output

Write to the output file the number of moves it takes to solve the puzzle. This number will not exceed 1018.


Sample Input

#13

AB BC CA BA CB AC
#22

AB BA CA BC CB AC


Sample Output

#17
#25
这题真是憋了我好久,看代码都看不明白啊啊啊啊 何况题都不明白啊啊啊啊

题的意思是按照他给的顺序操作汉诺塔的碟子 连着的操作不操作同一个盘子 

什么意思?好比说对于AB AC都可以操作 但是他给的顺序 是AB在AC的前面 那我就应该优先操作AB (如果条件允许的话)

题解的意思:我记录每组相反操作的优先级 然后比较 AB\AC   BC\BA  CA\CB的优先级高低 然后套用狭义或者广义的汉诺塔规律╭(╯^╰)╮

看构造数组时候联想到广义版的汉诺塔 狭义的

2077 汉诺塔IV (复制过来自带链接好高端 )
(是不是有那么一点像 ) 暂且不提广义的 ,但从1到3必须经过2过渡 与 从1 到2 必须经过3 本质上一样的 所以  AB或者AC成环 而其他的无需判断就是狭义的啦 
对于A->B->C->A 或者A->C->B->A 这种环 相当于广义的汉诺塔 

而另一种 BC成环的 因为要从A挪过去嘛 步数是狭义的求和了当然正常啦

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
ll a[35],b[35],c[35];
int f[10];
char s[10];
int main()
{
int n,i,j,k;
a[1]=b[1]=c[1]=1;
for(i=2;i<=30;i++)
{
a[i]=a[i-1]*2+1;
c[i]=c[i-1]*3+2;
b[i]=b[i-1]+c[i-1]+1;
}
while(~scanf("%d",&n)){
for(i=1;i<=6;i++)
{
scanf("%s",s);
k=(s[0]-'A')*3+s[1]-'A';
f[k]=i; //优先级
}
if(f[1]<f[2]){
if(f[3]<f[5])  printf("%I64d\n",c
);
else if(f[7]<f[6]) printf("%I64d\n",b
);
else printf("%I64d\n",a
);
}
else{
if(f[6]<f[7]) printf("%I64d\n",c
);
else if(f[5]<f[3]) printf("%I64d\n",b
);
else  printf("%I64d\n",a
);
}
}

}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: