您的位置:首页 > 其它

UVA_1593: Alignment of Code

2015-10-05 22:24 417 查看

Description

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other
tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed
at position p1 = 1; the second words on each line are printed at the minimal possible position
p2, such that all first words end at or before position
p2 - 2; the third words on each line are printed at the minimal possible position
p3, such that all second words end at or before position
p3 - 2, etc. For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII
punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters
long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that
i-th word on each line starts at the same position
pi.

Note for the Sample:The `

' character in the example below denotes a space character
in the actual files (ASCII code 32).

Sample Input

start:  integer;    // begins here
stop: integer; //  ends here
s:  string;
c:   char; // temp


Sample Output

start: integer; // begins here
stop:  integer; // ends   here
s:     string;
c:     char;    // temp


分析:本题可以直接把数据放在vector中,定义一个1000的vector数组,一次读一行,然后对一行再读字符串,读一次比较一次字符串长度大小;读取完了就输出。

#include <iostream>
#include <vector>
#include <string>
#include <sstream>
#include <cstdio>

using namespace std;

const int maxn = 1010;
vector<string> file[maxn];
int maxlen[200];

int main()
{
int cnt = 0;
string line;

while(getline(cin,line))
{
stringstream ss(line);
int hang=0;
string s;
while(ss>>s){
file[cnt].push_back(s);
if(!cnt || (s.length()>maxlen[hang]))
maxlen[hang]=s.length();
hang++;
}
cnt++;
}

for(int i=0; i<cnt; i++)
{
int sz = file[i].size();
for(int j=0; j<sz; j++)
{
int hang=maxlen[j]+1;
cout << file[i][j];
if(j<sz-1)for(int k=0; k<hang-file[i][j].length(); k++)putchar(' ');
}
putchar('\n');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: