您的位置:首页 > 其它

HDU1796-How many integers can you find

2015-10-05 12:45 369 查看


How many integers can you find

Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3867 Accepted Submission(s): 1088



Problem Description

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10},
all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

For each case, output the number.

Sample Input

12 2
2 3


Sample Output

7


题意:问在1~n-1这几个数,能被一个集合中的某个数整除的数的个数。

思路:容斥就可以解决。‘
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long ll;
int n,m;
vector<int> num;
int gcd(int a,int b){
if(b==0) return a;
return gcd(b,a%b);
}
int Lcm(int a,int b){
return a/gcd(a,b)*b;
}
void solve(){
vector<int> dig;
int ans = 0;
for(int i = 1; i < (1<<m); i++){
dig.clear();
for(int j = 0; j < m; j++){
if(i & (1<<j)) dig.push_back(j);
}
int t = 1;
for(int j = 0; j < dig.size(); j++){
t = Lcm(t,num[dig[j]]);
}
if(dig.size()%2==0) ans -= n/t;
else ans += n/t;
}
cout<<ans<<endl;
}
int main(){

while(~scanf("%d%d",&n,&m)){
n--;
num.clear();
int tn;
for(int i = 0; i < m; i++){
scanf("%d",&tn);
if(tn!=0) num.push_back(tn);
}
m = num.size();
solve();

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: