您的位置:首页 > 其它

poj 1942 Paths on a Grid 【数学题】

2015-10-05 11:29 423 查看
[align=center]Paths on a Grid[/align]

Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 23342
Accepted: 5746
Description
Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2).
So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:



Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input
The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension.
Input is terminated by n=m=0.
Output
For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit
to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input
5 4
1 1
0 0

Sample Output
126
2

Source
Ulm Local 2002

思路:

因为只能够往上或者往右走,所以只能够往右走m步,往上走n步,所以在给定方向上的步数是固定的,所以我们可以把它抽象成数学上的组合问题,在n+m个位置上抽取n个为止来放上,剩下的m个位置用来放右,具体看代码:(c 5 2=5*4/(2*1))

注意:题上给的32位要用无符号的unsigned或者用double

代码:

#include <stdio.h>
#include <string.h>
double n,m;
double f()
{
double sum=1.0;
double a=n+m;
double b=n<m?n:m;
while(b)
{
sum*=((a--))/((b--));
}
return sum;
}
int main()
{
while(scanf("%lf%lf",&n,&m)&&(n||m))
{
printf("%.0lf\n",f());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: