您的位置:首页 > 其它

HDU 1063 Exponentiation(高精度求幂)

2015-10-05 10:16 417 查看

Exponentiation

[align=left]Problem Description[/align]

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

 

[align=left]Input[/align]

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

 

[align=left]Output[/align]

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print
the decimal point if the result is an integer.

 

[align=left]Sample Input[/align]

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

 

[align=left]Sample Output[/align]

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

 
【思路分析】

   直接套的Java高精度模板。

代码如下:
import java.math.BigDecimal;
import java.util.Scanner;

public class Main{

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
BigDecimal num;
BigDecimal res = new BigDecimal("1");
int n;
while(in.hasNext()){
num = in.nextBigDecimal();
n = in.nextInt();
res = num.pow(n);
res
4000
= res.stripTrailingZeros();//除去后导零
String out = res.toPlainString();
//返回不带指数字段的此 BigDecimal 的字符串表示形式,toString()是以科学计数法输出
if(out.charAt(0) == '0')
out = out.substring(1);
System.out.println(out);
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: