您的位置:首页 > 其它

HDU 5119 DP 滚动数组,dp求异或

2015-10-04 21:54 274 查看

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others) Memory Limit: 510000/510000 K (Java/Others)

Total Submission(s): 1544 Accepted Submission(s): 612



[align=left]Problem Description[/align]
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

[align=left]Input[/align]
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

[align=left]Output[/align]
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

[align=left]Sample Input[/align]

2
3 2
1 2 3
3 3
1 2 3


[align=left]Sample Output[/align]

Case #1: 4
Case #2: 2

HintIn the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.


[align=left]Source[/align]
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

[align=left]Recommend[/align]
liuyiding

让求从n个数中任取任意个数(可以取0个);

看可以将取出的所有数异或之后有多少>=m的取法

#include <iostream>
#include <cstdio>
#include <algorithm>
#include<cstring>
using namespace std;
long long f[2][1100100];  //会RE
int a[45];
int main()
{
int t,ii,n,i,j,Min,m;
long long  ans;
scanf("%d",&t);
for (ii=1; ii<=t; ii++)
{
scanf("%d%d",&n,&m);
for (i=1; i<=n; i++)
scanf("%d",&a[i]);
memset(f,0,sizeof(f));
f[0][0]=1;
ans=0;
for (i=1; i<=n; i++)
for (j=0; j<1000000; j++)
f[i%2][j]=f[(i-1)%2][j]+f[(i-1)%2][j^a[i]];  //会异或之后 RE,所以开大点
for (i=m; i<1000000; i++)
ans+=f[n%2][i];
printf("Case #%d: %lld\n",ii,ans);
}
}


#include <iostream>
#include<cstring>
#include<cstdio>
#include<set>
#define LL long long
using namespace std;
const int maxn = 1000010;
LL dp[45][maxn];
int a[45];
int main()
{
int T;
int n,m;
int cas = 0;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
{
scanf("%d",&a[i]);
}
LL ans = 0;
dp[0][0] = 1;  //取0个数时为1
for(int i=1; i<=n; i++)  //将所有运算结果保存在[i][j]j中,i表示运算到了第i+1个数了.
{
for(int j=0; j<maxn; j++)
{
dp[i][j] += dp[i-1][j];
dp[i][(j^a[i])] += dp[i-1][j];
}
}
for(int i = m;i < maxn; i++)
ans+=dp
[i];
printf("Case #%d: %I64d\n",++cas,ans);
}
return 0;
}

#include<iostream>
#include<cstring>
#include<cstdio>
const int Maxn =1000000;

using namespace std;

int a[100];
long long  dp[42][1000100];
int main()
{
int n,T,m;
while(~scanf("%d",&T))
{
int Case=0;
while(T--)
{
Case++;
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&m);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);

dp[0][0]=1;
long long ans=0;
for(int i=0; i<n; i++)
{
for(int j=0; j<=Maxn; j++)  //将所有运算结果保存在[i][j]j中,i表示运算到了第i+1个数了.
{
dp[i+1][j]+=dp[i][j];
dp[i+1][(j^a[i])]+=dp[i][j];

if((j^a[i])>=m)  //>的优先级大于^
ans+=dp[i][j];
}
}
if(m==0)  //也可以选0个数
ans++;
printf("Case #%d: %lld\n",Case,ans);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: