您的位置:首页 > 其它

UVA_213: Message Decoding

2015-10-04 12:23 253 查看

Description

Some message encoding schemes require that an encoded message be sent in two parts. The first part, called the header, contains the characters of the message. The second part contains a pattern that represents the message. You must write a
program that can decode messages under such a scheme.The heart of the encoding scheme for your program is a sequence of ``key" strings of 0's and 1's as follows:


The first key in the sequence is of length 1, the next 3 are of length 2, the next 7 of length 3, the next 15 of length 4, etc. If two
adjacent keys have the same length, the second can be obtained from the first by adding 1 (base 2). Notice that there are no keys in the sequence that consist only of 1's.The keys are mapped to the characters in the header in order. That is, the first key
(0) is mapped to the first character in the header, the second key (00) to the second character in the header, thekth key is mapped to the
kth character in the header. For example, suppose the header is: AB#TANCnrtXcThen 0 is mapped to A, 00 to B, 01 to #, 10 to T, 000 to A, ..., 110 to X, and0000 to c.The encoded message contains only 0's and 1's and possibly carriage returns, which
are to be ignored. The message is divided into segments. The first 3 digits of a segment give the binary representation of the length of the keys in the segment. For example, if the first 3 digits are 010, then the remainder of the segment consists of keys
of length 2 (00, 01, or 10). The end of the segment is a string of 1's which is the same length as the length of the keys in the segment. So a segment of keys of length 2 is terminated by 11. The entire encoded message is terminated by 000 (which would signify
a segment in which the keys have length 0). The message is decoded by translating the keys in the segments one-at-a-time into the header characters to which they have been mapped.

Input

The input file contains several data sets. Each data set consists of a header, which is on a single line by itself, and a message, which may extend over several lines. The length of the header is limited only by the fact that key strings have
a maximum length of 7 (111 in binary). If there are multiple copies of a character in a header, then several keys will map to that character. The encoded message contains only 0's and 1's, and it is a legitimate encoding according to the described scheme.
That is, the message segments begin with the 3-digit length sequence and end with the appropriate sequence of 1's. The keys in any given segment are all of the same length, and they all correspond to characters in the header. The message is terminated by 000.Carriage
returns may appear anywhere within the message part. They are not to be considered as part of the message.

Output

For each data set, your program must write its decoded message on a separate line. There should not be blank lines between messages.

Sample Input

TNM AEIOU
0010101100011
1010001001110110011
11000
$#**\
0100000101101100011100101000


Sample Output

TAN ME
##*\$


分析:首先读取字符串,然后读取三字节长度,根据长度读取接下来的二进制串,如果读到(1<<len)-1则返回; 对于二进制编码与字符串的对应关系的建立可以找到公式,2^n - n -1就是要输出的那个字符,其中n是长度

#include <stdio.h>
#include <string.h>
#include <math.h>

const int maxn = 1000;
char decode[maxn];

int readchar()
{
while(1)
{
int c = getchar();
if(c!='\n' && c!='\r')return c;
}
}

int readline(char* s)
{
int i = 0;
int c = readchar();
while(1)
{
if(c==EOF)return 0;
s[i++] = c;
c = getchar();
if(c=='\n' || c=='\r')break;
}
s[i] = 0;
return 1;
}

int getheader()
{
int c;
int len = 0;
for(int i=0; i<3; i++)
{
c = readchar();
len <<= 1;
len+=c-'0';
}
return len;
}

void getcode(int len)
{
int c;
int endc = (1<<len) -1;
int code = 0;
while(1)
{
code = 0;
for(int i=0; i<len; i++)
{
c = readchar();
code <<= 1;
code += c-'0';
}
if(code>=endc)return;
int index = endc+code-len;
putchar(decode[index]);
}
}

int main()
{
int c;

while(readline(decode))
{
while(1)
{
int len = getheader();
if(len==0)break;
getcode(len);
}
putchar('\n');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: