您的位置:首页 > 其它

hdu1024Max Sum Plus Plus【状态dp 滚动数组】

2015-10-04 11:00 435 查看
[align=left]Problem Description[/align]
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 

[align=left]Input[/align]
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.

Process to the end of file.

 

[align=left]Output[/align]
Output the maximal summation described above in one line.

 

[align=left]Sample Input[/align]

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

 

[align=left]Sample Output[/align]

6
8

1003的升级版==就像之前看1505city game 和 1506Largest
Rectangle in a Histogram 没看出来二者有什么关系一样 ==

这次做完了1003maxsum 依旧没做出来1024更何况1003的写法就不对→_→

状态转移方程 dp[i][j]=max(dp[i][j-1]+a[j],max(dp[i-1][k])+a[j]) 前者是与之前的成为一组 后者是独立成组

dp[i][j]表示前j个数组成i组 而dp[i-1][k]是在j=j-1时的mmmax (怪不得他的序号就是j-1==)即mmax[j-1]

而mmax[]只有在下一次i=i+1 j=j 这个对应位置会被用到 恰恰说明了dp[i-1][k] 的本质是为了取上一次循环中的最大值

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[1000005],dp[1000005],mmax[1000005],n,m,mmmax;
int main()
{
while(~scanf("%d%d",&m,&n))
{
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
memset(dp,0,sizeof(dp));
memset(mmax,0,sizeof(mmax));
for(int i=1;i<=m;i++)
{
mmmax=-0x3f3f3f3f;
for(int j=i;j<=n;j++)
{
dp[j]=max(dp[j-1]+a[j],mmax[j-1]+a[j]);
mmax[j-1]=mmmax;
mmmax=max(dp[j],mmmax);
}
}
printf("%d\n",mmmax);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: