您的位置:首页 > 其它

UVA - 489 Hangman Judge

2015-10-03 21:21 381 查看
Description



In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given
as follows:

The contestant tries to solve to puzzle by guessing one letter at a time.
Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

______
|  |
|  O
| /|\
|  |
| / \
__|_
|   |______
|_________|


If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next
line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of
-1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.


分析:本题有三种情况,一是猜中所有字母,一是猜错7次,一是既没有猜中所有字母也没有猜错7次

#include <stdio.h>
#include <string.h>

const int maxn = 100010;
char computer[maxn];
int visit[maxn];
char guess[maxn];

int complete(int len)
{
for(int i=0; i<len; i++)
if(!visit[i])return 0;
return 1;
}

int main()
{
int kase;
int c_com;
while(~scanf("%d",&kase))
{
if(kase==-1)break;
scanf("%s%s",computer,guess);
memset(visit,0,sizeof(visit));

c_com = 0;
int gi = 0; //guess_index
int len = strlen(computer);
int len1 = strlen(guess);
while(gi<len1 && c_com<7 && !complete(len))
{
int right = 0;
for(int i=0; i<len; i++)
{
if(!visit[i] && computer[i] == guess[gi]){right=1;visit[i]=1;}
}
gi++;
if(!right)c_com++;
}
printf("Round %d\n",kase);
if(c_com>=7)printf("You lose.\n");
else if(complete(len))printf("You win.\n");
else printf("You chickened out.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: