您的位置:首页 > 其它

hdu1796How many integers can you find

2015-10-03 16:12 232 查看

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5795 Accepted Submission(s): 1668


Problem Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another
set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.


Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative
and won’t exceed 20.


Output
For each case, output the number.


Sample Input
12 2
2 3




Sample Output
7




Author
wangye


Source
2008 “Insigma International
Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

/*
题目大意:给定n和一个大小为m的集合,集合元素为非负整数。
为1...n内能被集合里任意一个数整除的数字个数。n<=2^31,m<=10
解题思路:容斥原理地简单应用。
先找出1...n内能被集合中任意一个元素整除的个数,
再减去能被集合中任意两个整除的个数,即能被它们两只的最小公倍数整除的个数,
因为这部分被计算了两次,然后又加上三个时候的个数,然后又减去四个时候的倍数...
最后判断下集合元素的个数为奇还是偶,奇加偶减。
*/
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
int n,m;
vector<int>p;

int gcd(int a,int b){
    if(a<b)
        swap(a,b);
    if(b==0)
        return a;
    return gcd(b,a%b);
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        p.clear();
        int x;
        for(int i=1;i<=m;i++){
            scanf("%d",&x);
            if(x!=0)
                p.push_back (x);
        }
        int sum=0;
        for(int msk=1;msk<(1<<p.size());msk++){
            int mult=1,bits=0;
            for(int i=0;i<(int)p.size();i++)
                if(msk&(1<<i)){
                    ++bits;
                    mult=p[i]/gcd(p[i],mult)*mult;  //可能爆int
                }
            int cur=(n-1)/mult;
            if(bits&1)
                sum+=cur;
            else
                sum-=cur;
        }
        printf("%d\n",sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: