您的位置:首页 > 其它

hd1051 Wooden Sticks

2015-10-03 12:51 253 查看

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15221 Accepted Submission(s): 6246


[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

[align=left]Sample Output[/align]

2
1
3

思路:先按木条长度递减排序,若相等按重量大的优先,然后遍历整个数据,符合条件就用一个平行数组标记遍历过,遍历完一组计数1,循环整个即可!

我的这种其实
4000
就是最笨的遍历!凑乎的过了!

#include <iostream>
#include<algorithm>
using namespace std;
typedef struct{
int l,w;}sticks;

bool cmp(sticks a,sticks b)
{
if(a.l == b.l)
return a.w > b.w;
else
return a.l > b.l;
}

int main()
{
sticks a[5001];
int t,n,i,count,record;
cin >>t;
while(t--)
{
int sign[5001]={0};//用于标记木条是否遍历过
count = 0;//记录时间
cin >> n;
for(i=0;i<n;i++)
cin >> a[i].l >> a[i].w;
sort(a,a+n,cmp);//按长度递减排序,如果相等重量大的优先
/* for(i=0;i<n;i++)
cout << a[i].l <<" "<< a[i].w << endl;*/

for(i=0;i<n;i++)
{
record = i;//记录起始木条位置
if(sign[record] == 0)//判断此木条是否遍历过
{
for(int j=record+1;j<n;j++)
{
if(a[j].w <= a[record].w &&sign[j] == 0)
{
record = j;
sign[j] = 1;//标记此木条已遍历
}
}
count++;//时间增加一

}
}
cout << count << endl;
}

return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: