您的位置:首页 > 其它

cleaning_shifts

2015-10-03 11:42 281 查看
Cleaning Shifts

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13909Accepted: 3572
Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and
the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input
3 10
1 7
3 6
6 10


Sample Output
2


Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

Source

USACO 2004 December Silver

#include <cstdio>

#include <cstring>

#include <algorithm>

using namespace std;

const int MAXN = 25005;

struct cow{

int f, r;

}s[MAXN];

typedef struct cow cow;

int n, t, tail, time=0;

int cmp(cow a,cow b){//自定义排序,如果是结构体,应写上结构体的名称

if(a.f==b .f)return a.r>b.r;

else return a.f<b.f;

}

int main(){

freopen("A.txt","r",stdin);

int n,t,i;

memset(s, 0, sizeof(s));

scanf("%d%d", &n, &t);

for(i = 1; i <= n; i++) scanf("%d%d", &s[i].f, &s[i].r);

sort(s + 1, s + n + 1, cmp);

int start=s[1].f;

if(start!=1){printf("-1");return 0;} //提前结束不符合条件的案例

int end1=s[1].r;

int ans=1;i=2;

while(end1<t&&i<=n)

{//printf("#");//用以识别循环是否为死循环

if(s[i].f>end1+1)

break;

int big=end1; /*在小循环内定义一个更大变量,以end1为坐标,直到把可能被包含的数据覆盖掉,循环结束,这是很好的一个技巧*/

while(i<=n&&end1+1>=s[i].f)

{

big=max(big,s[i].r);

i++;

}

ans++;

end1=big;

}

if(end1>=t)

printf("%d\n",ans);

else printf("-1\n");

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: