您的位置:首页 > 其它

HDU 2070 Fibbonacci Number

2015-10-02 16:39 232 查看



Fibbonacci Number


Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13400 Accepted Submission(s): 6677



Problem Description

Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0

f(1) = 1

f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

Input

Each test case consists of one integer n in a single line where 0≤n≤50.
The input is terminated by -1.

Output

Print out the answer in a single line for each test case.

Sample Input

3
4
5
-1


Sample Output

2
3
5

HintNote:
you can use 64bit integer: __int64


#include<stdio.h>
__int64 a[55]={0,1};
int main()
{
int i;
int m;
for(i=2;i<51;i++)
a[i]=a[i-1]+a[i-2];
while(scanf("%d",&m)&&(m!=-1))
{
printf("%I64d\n",a[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: