您的位置:首页 > 其它

弱校联萌十一大决战之强力热身E Rectangle初中组合数学

2015-10-01 21:15 405 查看
题目啊 ~~

frog has a piece of paper divided into \(n\) rows and \(m\) columns. Today, she would like to draw a rectangle whose perimeter is not greater than \(k\).
 
 



There are \(8\) (out of \(9\)) ways when \(n = m = 2, k = 6\)
 
Find the number of ways of drawing.


Input

The input consists of multiple tests. For each test:
 
The first line contains \(3\) integer \(n, m, k\) (\(1 \leq n, m \leq 5 \cdot 10^4, 0 \leq k \leq 10^9\)).


Output

For each test, write \(1\) integer which denotes the number of ways of drawing.


Sample Input

2 2 6
1 1 0
50000 50000 1000000000


Sample Output

8
0
1562562500625000000


智商是硬伤→_→这题居然从一开始就想歪了只是取两个点而已嘛~然后又是有范围的 那么一定不是O(n^3)的算法==

假设长度固定为i,那么满足周长的条件下最宽宽度分为两种情况1、>m 2、0~m之间的

对于情况一 很显然宽度的边上能够取得的点是C(m,2)个

情况二就比较复杂啦 可取得的情况 从(m-1+1)、(m-2+1)到(m-(k/2)+i-1)都可以 对这组式子求和 得

[(k/2-i)*m-(k/2-i+1)/2*(k/2-i)+(k/2-i)]

#include <iostream>
#include<cstdio>
using namespace std;
long long n,m,k,ans;
int main()
{
while(~scanf("%lld%lld%lld",&n,&m,&k))
{
ans=0;
for(int i=1;i<=n;i++)
{
if(k/2-i<=m&&k/2-i>=0)
{
ans+=(n-i+1)*(2*m-k/2+i+1)*(k/2-i)/2;
}
else if(k/2-i>m)
ans+=(n-i+1)*(1+m)*m/2;
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: