您的位置:首页 > 其它

Find them, Catch them

2015-10-01 00:04 351 查看
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1

5 5

A 1 2

D 1 2

A 1 2

D 2 4

A 1 4

Sample Output

Not sure yet.

In different gangs.

In the same gang.

有两个黑帮,然后a操作问你x,y是否是一个黑帮里的,b操作代表x,y不在一个黑帮中。

食物链的精简版,和祖先的关系只有2种状态了。随便怎么搞都可以。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=1005;
int n,k,p[50005],r[50005],m;
void init()
{
for(int i = 1;i <= n;i++)
{
p[i] = i;r[i] = 0;
}
}
int find(int x)
{
if(x != p[x])
{
int pp = find(p[x]);
if(r[x] == r[p[x]])r[x] = 0;
else r[x] = 1;
p[x] = pp;
}
return p[x];
}
void union_set(int x,int y,int type)
{
int fx,fy;
fx = find(x);fy = find(y);
if(type)
{
p[fy] = fx;
if(r[fx] == r[fy])r[fx] = 0;
else r[fx] = 1;
}
}
int main()
{
#ifdef LOCAL
freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
//freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
#endif // LOCAL
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);getchar();
init();
while(m--)
{
char c;int a,b;
scanf("%c%d%d",&c,&a,&b);getchar();
if(c == 'D')
{
union_set(a,b,1);
}
else if(c == 'A')
{
union_set(a,b,0);
int fa = find(a);int fb = find(b);
if(fa != fb)
printf("Not sure yet.\n");
else
{
if(r[a] == r[b])
printf("In the same gang.\n");
else
printf("In different gangs.\n");
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: