您的位置:首页 > 其它

食物链

2015-09-30 23:54 253 查看
Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。

现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。

有人用两种说法对这N个动物所构成的食物链关系进行描述:

第一种说法是”1 X Y”,表示X和Y是同类。

第二种说法是”2 X Y”,表示X吃Y。

此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。

1) 当前的话与前面的某些真的话冲突,就是假话;

2) 当前的话中X或Y比N大,就是假话;

3) 当前的话表示X吃X,就是假话。

你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

第一行是两个整数N和K,以一个空格分隔。

以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。

若D=1,则表示X和Y是同类。

若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7

1 101 1

2 1 2

2 2 3

2 3 3

1 1 3

2 3 1

1 5 5

Sample Output

3

中文题= =,拿这个作为并查集入门实在是太坑了,首先确立几个操作,find->查祖先,union_set合并两棵树。

这题再加一个变量,表示该节点和祖先的关系。利用循环更新,因为不会用向量,只能用归纳法来推导关系,r[x] = (r[x] + r[p[x]])%3;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn=1005;
int n,k,p[50005],r[50005];
void init()
{
for(int i = 1;i <= n;i++)
{
p[i] = i;r[i] = 0;
}
}
int find(int x)
{
if(x != p[x])
{
int pp = find(p[x]);
r[x] = (r[x] + r[p[x]])%3;
p[x] = pp;
}
return p[x];
}
bool union_set(int x,int y,int type)
{
int fx,fy;
fx = find(x);fy = find(y);
if(fx == fy)
{
if((r[y] - r[x] + 3)%3 != type)return true;
else return false;
}
p[fy] = fx;
r[fy] = (r[x] - r[y] + type + 3)%3;
return false;
}
int main()
{
#ifdef LOCAL
freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
//freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
#endif // LOCAL
scanf("%d%d",&n,&k);
init();
int temp,x,y;
int ans = 0;
while(k--)
{
scanf("%d%d%d",&temp,&x,&y);
if(x > n||y > n||(x == y&&temp == 2))ans++;
else if(union_set(x,y,temp - 1))ans++;
}
printf("%d\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: