您的位置:首页 > 其它

hdoj 5491 The Next 【lowbit 的使用】

2015-09-30 22:17 351 查看

The Next

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 926    Accepted Submission(s): 381


Problem Description

Let L denote
the number of 1s in integer D’s
binary representation. Given two integers S1 and S2,
we call D a
WYH number if S1≤L≤S2.

With a given D,
we would like to find the next WYH number Y,
which is JUST larger than D.
In other words, Y is
the smallest WYH number among the numbers larger than D.
Please write a program to solve this problem.

 

Input

The first line of input contains a number T indicating
the number of test cases (T≤300000).

Each test case consists of three integers D, S1,
and S2,
as described above. It is guaranteed that 0≤D<231 and D is
a WYH number.

 

Output

For each test case, output a single line consisting of “Case #X: Y”. X is
the test case number starting from 1. Y is
the next WYH number.
 

Sample Input

3
11 2 4
22 3 3
15 2 5

 

Sample Output

Case #1: 12
Case #2: 25
Case #3: 17

 

WYH数的定义:若x的二进制中1的个数num满足s1 <= num <= s2 则x是一个WYH数。

题意:给一个WYH数D、s1和s2,让你求出第一个大于D的WYH数。题目保证存在解。

lowbit性质:

对于满足[ x,  x + lowbit(x)) 的数,二进制中1的个数随数的增大是单调增的(注意区间不包括x + lowbit(x) 而且单调增不是严格的)。

思路:每次判断区间[x ~ x+lowbit(x))里面是否存在满足条件的WYH ,如果存在则在该区间找最终结果即叠加上最少需要增加的低位1,反之找下一个区间即[x+lowbit(x),  x + lowbit(x) + lowbit(x+lowbit(x)) )。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define LL long long
using namespace std;
LL lowbit(LL x){
return x & -x;
}
int Count(LL x)//1的个数
{
int sum = 0;
while(x)
{
if(x & 1)
sum++;
x >>= 1;
}
return sum;
}
int main()
{
int t, k = 1;
LL d;
int s1, s2;
scanf("%d", &t);
while(t--)
{
scanf("%lld%d%d", &d, &s1, &s2);
LL  ans = d + 1;
int cnt = Count(ans);
LL lb = lowbit(ans);
while(s1 > cnt || s2 < cnt)
{
int addnum = Count(lb-1);
if(s1 > cnt + addnum || cnt > s2)
{
ans += lb;//继续下一个区间
cnt = Count(ans);
lb = lowbit(ans);
}
else
{
ans += (1<<(max(cnt, s1)-cnt))-1;//叠加低位1
break;
}
}
printf("Case #%d: %lld\n", k++, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: