您的位置:首页 > 其它

HDOJ 题目5444 Elven Postman(BST模拟水啊。。。)

2015-09-30 11:29 337 查看

Elven Postman

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 975 Accepted Submission(s): 542



[align=left]Problem Description[/align]
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know.
Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully
like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having
the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.



[align=left]Input[/align]
First you are given an integer
T(T≤10)
indicating the number of test cases.

For each test case, there is a number n(n≤1000)
on a line representing the number of rooms in this tree.
n
integers representing the sequence written at the root follow, respectively
a1,...,an
where a1,...,an∈{1,...,n}.

On the next line, there is a number q
representing the number of mails to be sent. After that, there will be
q
integers x1,...,xq
indicating the destination room number of each mail.

[align=left]Output[/align]
For each query, output a sequence of move (E
or W)
the postman needs to make to deliver the mail. For that
E
means that the postman should move up the eastern branch and
W
the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

[align=left]Sample Input[/align]

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1


[align=left]Sample Output[/align]

E

WE
EEEEE


[align=left]Source[/align]
2015 ACM/ICPC Asia Regional Changchun Online

[align=left]Recommend[/align]
hujie | We have carefully selected several similar problems for you: 5493 5492 5491 5490 5489
只想说声卧槽,这个大水题啊,,直接模拟就好了,感觉怎么都能写,为毛他喵网赛的时候没有写,,连他喵题也没读,弱啊


题目大意:就是给个n,后边n个数。建BST,然后后边一个q,q个查询,问怎么从根走到那个点
ac代码



#include<stdio.h>
#include<string.h>
struct s
{
int ls,rs,val;
}node[10010];
int sz;
int newnode(int x)
{
++sz;
node[sz].ls=node[sz].rs=0;
node[sz].val=x;
return sz;
}
int insert(int tr,int x)
{
if(node.val==0)
return newnode(x);
if(x<node.val)
node.ls=insert(node.ls,x);
else
node.rs=insert(node.rs,x);
return tr;
}
void dfs(int tr,int x)
{
if(x<node.val)
{
printf("E");
dfs(node.ls,x);
}
else
if(x>node.val)
{
printf("W");
dfs(node.rs,x);
}
else
return;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int i;
sz=0;
memset(node,0,sizeof(node));
for(i=1;i<=n;i++)
{
int x;
scanf("%d",&x);
insert(1,x);
}
int q;
scanf("%d",&q);
while(q--)
{
int x;
scanf("%d",&x);
dfs(1,x);
printf("\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: