您的位置:首页 > 其它

poj 2689

2015-09-29 17:37 381 查看
Language:
Prime Distance
点击打开题目链接

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14583 Accepted: 3880
Description
The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number
that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers
that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.

Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair.
You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input
Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output
For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input
2 17
14 17

Sample Output
2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source
Waterloo local 1998.10.17

对于给定的区间L,R,求区间内聚力最近的两个素数和聚力最远的两个素数;

将区间L,R内的素数进行打表处理。。。打表方法借用kuangbin巨的方法。。。先将小范围(100000)的内的素数进行打表,对于题目区间只有1e6次方,晒出LR之间的合数从而确定,L、R之间的素数。L,R之间的合数必定为1-100000之间的素数的倍数,所以对于这枚举晒就好了;

 

kuangbin巨的代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <queue>
#include <stack>
#include <vector>
#include <math.h>
#include <map>
#include <stdlib.h>
#include <algorithm>

#define eps 1e-5
#define inf 0x3f3f3f3f
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b)  ((a)<(b)?(a):(b))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
#define lc rt<<1
#define rc rt<<1 | 1
#define getx2(a)  ((a)*(a))
#define Pi acos(-1.0)
#define N 100010

typedef long long LL;
using namespace std;
int prime
;
void getPrime()//素数打表1-100000
{
memset(prime,0,sizeof(prime));
for(int i=2; i<N; i++)
{
if(!prime[i])
{
prime[++prime[0]]=i;
}
for(int j=1; j<=prime[0]&&prime[j]<=N/i; j++)
{
prime[prime[j]*i]=1;
if(i%prime[j]==0)break;
}
}
}

bool isprime[1000010];
int prime2[1000010];
void getPrime2(int L,int R)///晒出L-R之间的素数
{
memset(isprime,1,sizeof(isprime));
if(L<2)L=2;
for(int i=1; i<=prime[0]&&(LL)prime[i]*prime[i]<=R; i++)
{
int s=ceil(1.0*L/prime[i]);///+(L%prime[i]>0);
if(s==1)s=2;
for(int j=s; (LL)j*prime[i]<=R; j++)
{
if((LL)j*prime[i]>=L)
{
isprime[j*prime[i]-L]=0;
}
}
}
prime2[0]=0;
for(int i=0; i<=R-L; i++)
{
if(isprime[i])
{
prime2[++prime2[0]]=i+L;//区间映射(数太大了,映射到小区间存)
}
}
}
int main()
{
getPrime();
int L,R;
while(~scanf("%d%d",&L,&R))
{
getPrime2(L,R);
if(prime2[0]<2)
printf("There are no adjacent primes.\n");
else
{
int p1=0,p2=inf,p3=0,p4=0;
for(int i=1;i<prime2[0];i++)
{
if(prime2[i+1]-prime2[i]<p2-p1)//简单的求距离最大最小
{
p2=prime2[i+1];
p1=prime2[i];
}
if(prime2[i+1]-prime2[i]>p4-p3)
{
p4=prime2[i+1];
p3=prime2[i];
}
}
printf("%d,%d are closest, %d,%d are most distant.\n",p1,p2,p3,p4);
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj