您的位置:首页 > 其它

PAT(甲级)1078

2015-09-29 10:44 323 查看


1078. Hashing (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table.
Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct
positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the
number, print "-" instead.
Sample Input:
4 4
10 6 4 15

Sample Output:
0 1 4 -


#include <cstdio>
#include <cmath>
#include <ctime>
#define SIZE 10004
#define MAX  2000

using namespace std;

bool hash[SIZE];
int prime[MAX];

bool isprime(int &n,int prime[],int &k){
int i =0;
for(i=0;i<k;i++)
if(n%prime[i] == 0)
return false;
return true;
}

int makeprime(int n,int prime[],int &k)
{
k=0;
int i;
prime[k++] =2;
int limit=sqrt(n);
for(i=3;i<=limit;i+=2)
if(isprime(i,prime,k))
prime[k++] = i;
int k1=k;
for (i; i <= n; i += 2){
if (isprime (i, prime, k1))
prime[k++] = i;
}
if(prime[k-1]<n){
for(i;;i+=2)
if(isprime(i,prime,k))
{prime[k++] = i; break;}
}
return prime[k-1];
}

int main()
{
int msize, n, i;
int k;
scanf ("%d%d", &msize, &n);
msize = makeprime (msize, prime, k);
for(i=0;i<n;i++)
hash[i]=false;
scanf("%d",&k);
hash[k%msize]=true;
printf("%d",k%msize);
for (i = 0; i < n-1; i++)
{
scanf("%d",&k);
int index0 = k%msize;
int j;
for(j=0;j<n;j++){
int index1 =(index0+j*j)%msize;
if(!hash[index1]){
hash[index1] = true;
printf(" %d",index1);
break;
}
}
if(j==n)
printf(" -");
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: