您的位置:首页 > 其它

PAT(甲级)1076

2015-09-29 10:40 423 查看


1076. Forwards on Weibo (30)

时间限制

3000 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view
and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are
counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered
from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated
by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are
counted.
Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:
4
5


#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>

using namespace std;
///////////////////////////////////////////////////////////////
//just use level array to indicate whether the node is visited
///////////////////////////////////////////////////////////////
const int SIZE =1003;
int level[SIZE];

vector<int> Follower[SIZE];
queue<int> que;

void Reset(int n){
for(int i=1;i<=n;i++)
{
level[i] = -1;
}
}

int BFS(int start,int level1){
int cur,cnt=0,count=0;
que.push(start);
level[start] =0;
while(!que.empty()){
cur = que.front();
cnt = level[cur];
if(cnt >= level1)
break;
int size = Follower[cur].size();
for(int i = 0;i<size;i++){
int index = Follower[cur][i];
if(level[index] == -1){
level[index] = cnt+1;
que.push(index);
count++;
}
}
que.pop();
}
return count;
}

int main()
{
int N,L,K;
freopen("test.txt","r",stdin);
scanf("%d%d",&N,&L);
for(int i=1;i<=N;i++){
int num,tmp;
scanf("%d",&num);
for(int j=0;j<num;j++){
scanf("%d",&tmp);
Follower[tmp].push_back(i);
}
}
scanf("%d",&K);
for(int i = 0;i<K;i++){
int num;
scanf("%d",&num);
Reset(N);
printf("%d\n",BFS(num,L));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: