您的位置:首页 > 其它

PAT(甲级)1075

2015-09-29 10:39 363 查看


1075. PAT Judge (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105),
the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the
i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th
problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in
increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.
Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

<pre name="code" class="cpp">#include <iostream>
#include <algorithm>
#define SIZE 10004

using namespace std;
////////////////////////////////////////////////
//DO NOT USE I INSTEAD OF J AS INDEX AGAIN!!!!!!!!!!!!!!!!!
//CARE: 1 sum==0 can be show in the list for it pass the compilers
//
//where is the bug?????
//  BUG::if I initilize score[] to -1 and if the input date is -1, I set it to 0 to display, where is the problem??
//  FIXED: if set -1 to 0, then next time comes the same id_p but the partinal score is 0, pass flag will
// not be set at all!!!!!!!!!!!!!!!!!!!
// ADVICE: seperate condition as clearly as possible, DO NOT TRY TO GROUP MANY CASES AS ONE, IT MAY HIDE BUGS!!!!!!
///////////////////////////////////////////////////////
struct Student{
int ID;
int score[5];
int sum;
int count;
static int tmp;
bool pass;   //PASS COMPILATION
Student();
};

int Student::tmp = 0;

Student::Student(){
ID = tmp++;
sum = 0;
count = 0;
score[0]=score[1]= score[2]=score[3]=score[4]=-2;       //original bug is here!!! the value using -1
pass = false;
}

bool mycmp(const Student &s1,const Student &s2){
if(s1.sum == s2.sum){
if(s1.count == s2.count)
return s1.ID < s2.ID;
else
return s1.count > s2.count;
}else
return s1.sum > s2.sum;
}

Student students[SIZE];

int main()
{
int N,K,M;
int full[5];
//	freopen("test.txt","r",stdin);
scanf("%d%d%d",&N,&K,&M);
for(int i=0;i<K;i++)
scanf("%d",&full[i]);
int index_stu,index_p,score;
for(int i=0;i<M;i++){
scanf("%d%d%d",&index_stu,&index_p,&score);
index_p--;
if(students[index_stu].score[index_p] < score){   //update score
students[index_stu].score[index_p] = score;
if(score == full[index_p])                  //perfect solved numbers
students[index_stu].count++;
if(score >= 0)
students[index_stu].pass = true;			//pass compilation
}
}

for(int i=1;i<=N;i++){                  //when seperate the sum from last loop, it become more concise
int *p = students[i].score;
for(int j=0;j<K;j++){
if(p[j] >0)
students[i].sum += p[j];
}
}

sort(students+1,students+N+1,mycmp);
//	cout <<"%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%\n";
int last,pre_sum=-1;
int count = 0;
for(int i=1;i<=N;i++){                                         //strating iterator has been modified
int sum = students[i].sum;
bool flag = students[i].pass;
if(flag){
count++;
if(sum != pre_sum){
last = count;
}
pre_sum = sum;
printf("%d %05d %d",last,students[i].ID,sum);
int *p = students[i].score;
for(int j=0;j<K;j++){            //index is j not i!!!!!!!!!!!!!!!
if (p[j] >= 0)
printf(" %d",p[j]);
else if(p[j] == -1)
printf(" 0");
else
printf(" -");
}
printf("\n");
}
}
if(!count){                                  //fix bug guarantee one show !!!!!!!!!!!!!!!!!!!!!!!!!
printf("1 %05d 0",students[1].ID);
int *p = students[1].score;
for(int j=0;j<K;j++){
if (p[j] >= 0)
printf(" %d",p[j]);
else if(p[j] == -1)
printf(" 0");
else
printf(" -");
}
}

//	fclose(stdin);
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: