您的位置:首页 > 其它

poj1942 Paths on a Grid(组合数)

2015-09-28 18:26 316 查看
Paths on a Grid

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 23307Accepted: 5740
Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste
your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:



Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up?
You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input
5 4
1 1
0 0

Sample Output
126
2

//poj1942 Paths on a Grid(组合数)
//题目大意:题中共有 n*m 个方格 ,从左下角开始,每次只能向上或向右走;
//求每次从左下角到右上角的路径共有多少条?
//首先,分析一下,当只有一个方格时(即n=m=1),有两个种走法,当有两个方格时(即n=2,m=1,或n=1,m=2),
//可知从左下到右上共需3步;当有三个方格时(即n=1,m=3 or n=3,m=1)从左下到右上共有4步,当有四个方格时;
//(n=2,m=2)从左下到右上共有四步,5、6、7、8个方格如此,所以当有n*m个方格时,从左下到右上共需 n+m步; 
//其中,当向上有n步,向右就有m步,当向上有m步数时,向右就有n步,因为从n+m步中选出向右的 n步时,向上的 
//步数也就确定了,可知总的走法就是从n+m步中选n步
//或选m步(都一样),即 从 n+m 选n步的组合数就是答案。
//但由于数据量有点大,同时,计算时也用到浮点型所以需要将变量定位浮点型 
#include<cstdio>
#include<algorithm>
using namespace std;
void fun(double n,double m)
{
	double sum;
	double x,y;
	x=m+n;
	y=min(n,m);
	sum=1.0;
	while(y>0)
	{
		sum*=(x--)/(y--);
	}
    printf("%.0f\n",sum);
}
int main()
{
	double n,m;
	while(scanf("%lf%lf",&n,&m)&&(n||m))
	{
		fun(n,m);
	}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: