您的位置:首页 > 其它

杭电OJ -- 2084 数塔(动态规划)

2015-09-28 09:06 369 查看
Problem Description

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?



已经告诉你了,这是个DP的题目,你能AC吗?



Input

输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。



Output

对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。



Sample Input

1
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5




Sample Output

30





很简单的一道动态规划的题目,很久都没有做过了,练练手。

#include <iostream>
#include <vector>
//#include <iterator>
#include <algorithm>
using namespace std;
/*动态规划的问题,属于很简单的一道题目
 */

int main()
{
	int num_of_case, height_of_tower;
	cin >> num_of_case;
	vector<int> tower;
	
	int num_of_num = (1 + 100) * 100 / 2;
	tower.reserve(num_of_num + 1); //事先分配好足够的内存
	int temp;

	while (num_of_case-- > 0)
	{
		cin >> height_of_tower;
		num_of_num = (1 + height_of_tower) * height_of_tower / 2;
		tower.push_back(0); //tower[0] = 0,不使用
		for (int i = 1; i <= num_of_num; ++i)
		{
			cin >> temp;
			//copy(istream_iterator<int>(cin), istream_iterator<int>(), back_inserter(tower));
			//cin >> back_inserter(tower); //得到输入
			tower.push_back(temp);
		}
		vector<int> value(tower.begin(), tower.end());
		//开始dp
		for (int j = num_of_num - height_of_tower, n = height_of_tower, i = 0; j > 0; --j)
		{
			value[j] = max(value[j + n], value[j + n - 1]) + value[j]; //基本上是状态转移方程
			if (++i == n - 1)
			{
				--n;
				i = 0;
			}
		}
		cout << value[1] << endl;
		tower.clear();
	}
	system("pause");
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: