您的位置:首页 > 大数据 > 人工智能

HDU 5475.An easy problem【思路】【2015 ACM/ICPC Asia Regional Shanghai Online】【9月26】

2015-09-26 19:39 701 查看
An easy problem

Problem Description

One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.

1. multiply X with a number.

2. divide X with a number which was multiplied before.

After each operation, please output the number X modulo M.

Input

The first line is an integer T(1≤T≤10),
indicating the number of test cases.

For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1≤Q≤105,1≤M≤109)

The next Q lines, each line starts with an integer x indicating the type of operation.

if x is 1, an integer y is given, indicating the number to multiply. (0<y≤109)

if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.

Output

For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.

Then Q lines follow, each line please output an answer showed by the calculator.

Sample Input

1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7


Sample Output

Case #1:
2
1
2
20
10
1
6
42
504
84


感谢大牛的博客

#include<cstdio>
#include<cstring>
using namespace std;
const int N=100000+10;
__int64 ans;
int f
,fl
;
int main(){
//freopen("out.txt","w",stdout);
int T,kase=1,x,y,n,m;
scanf("%d",&T);
while(T--){
ans=1;
printf("Case #%d:\n",kase++);
memset(fl,0,sizeof(fl));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++){
scanf("%d%d",&x,&y);
if(x==1){
fl[i]=1;
f[i]=y;
ans=(ans*y)%m;
}
else{
ans=1;
for(int j=1;j<i;j++){
if(j==y) fl[j]=0;
else if(fl[j])
ans=(ans*f[j])%m;
}
}
printf("%I64d\n",ans);
}
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: