您的位置:首页 > 理论基础 > 计算机网络

2015亚洲网络赛上海站1010A Sweet Journey

2015-09-26 15:04 756 查看
Problem Description

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will
regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)





Input

In the first line there is an integer t (1≤t≤50),
indicating the number of test cases.

For each test case:

The first line contains four integers, n, A, B, L.

Next n lines, each line contains two integers: Li,Ri,
which represents the interval [Li,Ri] is
swamp.

1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.

Make sure intervals are not overlapped which means Ri<Li+1 for
each i (1≤i<n).

Others are all flats except the swamps.



Output

For each text case:

Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.



Sample Input

1
2 2 2 5
1 2
3 4




Sample Output

Case #1: 0




反正也是一个签到题,剧透一下也未尝不可嘛~~

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int l[105],r[105],len,a,b,t,n;
bool vis[100005];
int main()
{
    scanf("%d",&t);
    int cas=1;
    while(t--)
    {
        scanf("%d%d%d%d",&n,&a,&b,&len);

        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&l[i],&r[i]);
            for(int j=l[i]+1;j<=r[i];j++)
            vis[j]=1;
        }
        int sum=0,maxn=999999;
        for(int i=1;i<=len;i++)
        {
            if(vis[i]==0) sum+=b;
            else sum-=a;
            if(maxn>sum&&sum<0) maxn=sum;
        }
        printf("Case #%d: ",cas++);
        if(maxn>=0) printf("0\n");
        else printf("%d\n",-maxn);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: