您的位置:首页 > 其它

POJ——3624 Charm Bracelet

2015-09-26 12:05 274 查看
Charm Bracelet

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 27943Accepted: 12589
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1
≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7

Sample Output
23

0 1背包
#include<stdio.h>

#include<string.h>

#include<math.h>

#include<stdlib.h>

#include<ctype.h>

#include<iostream>

#include<string>

#include<algorithm>

#include<set>

#include<vector>

#include<queue>

#include<map>

#include<numeric>

#include<stack>

#include<list>

const int INF=1<<30;

const int inf=-(1<<30);

const int MAX=100010;

using namespace std;

struct data

{

int x,y;

} a[10010];

int dp[100010];

int main()

{

int n,m;

while(~scanf("%d%d",&n,&m))

{

memset(dp,0,sizeof(dp));

for(int i=1; i <= n; i++)

scanf("%d%d",&a[i].x,&a[i].y);

for(int i=1;i <= n; i++)

for(int j=m; j>=a[i].x; j--)

dp[j]=max(dp[j],dp[j-a[i].x]+a[i].y);

cout<<dp[m]<<endl;

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: