您的位置:首页 > 其它

PAT(甲级)1064

2015-09-26 11:10 393 查看


1064. Complete Binary Search Tree (30)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0

Sample Output:
6 3 8 1 5 7 9 0 2 4


#include <iostream>
#include <algorithm>
#define SIZE 1003

using namespace std;
/////////////////////////////////////////////////////////
//use the proberty that midorder travel sequence is the
//sorted non-decrease list
////////////////////////////////////////////////////////

int input[SIZE];
int output[SIZE];

static int k=0;

void build_cbt(int input[],int output[],int pos, int N){
if(pos > N-1)
return;
else{
build_cbt(input,output,2*pos+1,N);
output[pos] = input[k++];
build_cbt(input,output,2*pos+2,N);
}
}

int main()
{
int N;
freopen("test.txt","r",stdin);
scanf("%d",&N);
for(int i=0;i<N;i++){
scanf("%d",&input[i]);
}
sort(input,input+N);
build_cbt(input,output,0,N);
for(int i=0;i< N-1;i++)
printf("%d ",output[i]);
printf("%d\n",output[N-1]);

fclose(stdin);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: