您的位置:首页 > 其它

PAT(甲级)1044

2015-09-26 10:11 302 查看


1044. Shopping in Mars (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the
chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).

2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).

3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has
to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds.
All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order
of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again
all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:
1-5
4-6
7-8
11-11

Sample Input 2:
5 13
2 4 5 7 9

Sample Output 2:
2-4
4-5

#include <iostream>
#define SIZE 100005

using namespace std;

///////////////////////////////////////////////////////////
//  version2
// this method is relatively hard to implement,please refer to others
//////////////////////////////////////////////////////////

struct Iterm{
int start;
int end;
};

int a[SIZE];
Iterm record[SIZE];
///////////////////////////////////////////////////////////////////////////////////////////////
//i:starting position of array[]
//remain: remove a[i], the sum left
//value:standard value, here is M
//n: the number of array[]
//flag: indicate whether find a element bigger than M
// this function is of key importance, for it can eliminate the repeated iteration
////////////////////////////////////////////////////////////////////////////////////////
int fun(int i,unsigned long &remain,int value,int n,bool &flag){  //return the termination position
if(remain >= value){  //to avoid case such as 1 2 3 4 16 while to get 15 etc
return i-1;
}

for(int j=i;j<n;j++){
if(a[j] >= value){
remain = a[j];   //reset remain if find a element bigger than value
flag = true;
return j;
}
remain += a[j];
if(remain >= value)
return j;
}
}

int main()
{
int i,j,k,N,M;
//	freopen("test.txt","r",stdin);
scanf("%d%d",&N,&M);
for(i=0;i<N;i++)
scanf("%d",&a[i]);
unsigned long tmp=-1,sum=0;
k=0;
bool found=false;
j = 0;
for(i=0;i<N;i++){        //sum is the accumulated sum of a[i],a[i+1]...a[j]
bool flag =false;
j = fun(j,sum,M,N,flag);  //the function stops when the sum is larger than or equal to M
if(sum == M){
found = true;
if(flag){
printf("%d-%d\n",j+1,j+1);
}
else
printf("%d-%d\n",i+1,j+1);
}else if(sum > M && sum <= tmp & !found){
if(sum < tmp)
k=0;
if(flag){
record[k].start = j+1;
}
else
record[k].start = i+1;
record[k].end = j+1;
k++;
tmp = sum;
}
if(flag)
i = j;
sum -= a[i];
j++;
}

if(!found){
for(i=0;i<k;i++)
printf("%d-%d\n",record[i].start,record[i].end);
}

//	fclose(stdin);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: