您的位置:首页 > 其它

PAT(甲级)1043

2015-09-26 10:10 267 查看


1043. Is It a Binary Search Tree (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All
the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11

Sample Output 1:
YES
5 7 6 8 11 10 8

Sample Input 2:
7
8 10 11 8 6 7 5

Sample Output 2:
YES
11 8 10 7 5 6 8

Sample Input 3:
7
8 6 8 5 10 9 11

Sample Output 3:
NO


#include <iostream>
#define SIZE 1003

using namespace std;
////////////////////////////////////////////////////
//seperate levels make codes look clear!
//subtrees can divide into four cases:
//1) no left subtree
//2) no right subtree
//3) both left and right subtree
//4) no subtrees at all
//
// adding a judgement that if start > end return true can handle most of the cases above
/////////////////////////////////////////////////////////
struct Node{
Node(int n){
value = n;
left =NULL;
right = NULL;
}
Node();
int value;
Node *left;
Node *right;
};

Node::Node(){
value =0;
left=right=NULL;
}

bool con_bin_tree(Node * &ptr,int input[],int start,int end) {
if(start > end)
return true;
int rootvalue = input[start];
ptr = new Node(rootvalue);
if(ptr == NULL){
printf("FAIL TO ALLOCATE NODE\n");
return false;
}
if(start == end)        //terminate recurrsive
return true;
else{
int end1;
int i = start+1;
while(i <=end && input[i] < rootvalue)
i++;
end1 = i-1;
for(;i<=end;i++)
if(input[i] < rootvalue)
return false;
bool flag1,flag2;
flag1 = con_bin_tree(ptr->left,input,start+1,end1);
flag2 = con_bin_tree(ptr->right,input,end1+1,end);
return (flag1&flag2);
}
}

bool con_mirror(Node * &ptr,int input[],int start,int end){
if(start > end)
return true;
int rootvalue = input[start];
ptr = new Node(rootvalue);
if(ptr == NULL){
printf("FAIL TO ALLOCATE NODE\n");
return false;
}
if(start == end)
return true;
else{
int end1;
int i = start+1;
while(i <=end && input[i] >= rootvalue)
i++;
end1 = i-1;
for(;i<=end;i++)
if(input[i] >= rootvalue)
return false;
bool flag1,flag2;
flag1 = con_mirror(ptr->left,input,start+1,end1);
flag2 = con_mirror(ptr->right,input,end1+1,end);
return (flag1&flag2);
}
}

bool tree_construct(Node * &ptr,int input[],int start,int end){
bool flag = false;
bool bst = false;
int rootvalue = input[start];
if(start ==end){             //just one element in case that input[start+1] is invalid
ptr = new Node(rootvalue);
return true;
}
int i = start+1;
if(input[i] < rootvalue)   //take it as a binary tree
bst = true;
if(bst)
flag = con_bin_tree(ptr,input,start,end);
else
flag = con_mirror(ptr,input,start,end);
return flag;
}

int input[SIZE];
int output[SIZE];

void postorder1(Node * &root,int output[]){
static int k=0;
if(root == NULL)
return ;
else{
postorder1(root->left,output);
postorder1(root->right,output);
output[k++] = root->value;
}
}

void postorder(Node * &root,int output[],int N){
postorder1(root,output);
for(int i=0;i<N-1;i++)
printf("%d ",output[i]);
printf("%d\n",output[N-1]);
}

int main()
{
int N,tmp;
//	freopen("test.txt","r",stdin);
scanf("%d",&N);
for(int i = 0;i<N;i++){
scanf("%d",&input[i]);
}
Node *root = NULL;
bool flag = tree_construct(root,input,0,N-1);
if(flag){
printf("YES\n");
postorder(root,output,N);
}
else
printf("NO\n");
//	fclose(stdin);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: