您的位置:首页 > 其它

PAT(甲级)1041

2015-09-26 10:07 295 查看


1041. Be Unique (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


#include <cstdio>
#include <cstring>
#define SIZE 100005

int record[SIZE];
int input[SIZE];
int main()
{
int N,tmp;
scanf("%d",&N);
memset(record,0,sizeof(int)*SIZE);
int i,j;
for(i=0;i<N;i++){
scanf("%d",&tmp);
input[i] = tmp;
record[tmp]++;
}

for(i=0;i<N;i++){
j=input[i];
if(record[j] ==1){
printf("%d\n",j);
return 0;
}
}
printf("None\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: