您的位置:首页 > 其它

HDU 5444 Elven Postman(最优二叉树) 2015多校

2015-09-25 22:25 435 查看


Elven Postman

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 968 Accepted Submission(s): 535



Problem Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs
through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully
like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having
the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.





Input

First you are given an integer T(T≤10) indicating
the number of test cases.

For each test case, there is a number n(n≤1000) on
a line representing the number of rooms in this tree. n integers
representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing
the number of mails to be sent. After that, there will be q integers x1,...,xq indicating
the destination room number of each mail.



Output

For each query, output a sequence of move (E or W)
the postman needs to make to deliver the mail. For that E means
that the postman should move up the eastern branch and W the
western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.



Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1




Sample Output

E

WE
EEEEE




题意:输入n和n个点,q和q组询问,以这n个点的顺序建立最优二叉树,即对于根节点,其左子树大于根节点,右子树小于根节点。对于每组询问,输出从根节点到当前询问节点的路径,左子树输出W,右子树输出E。(ps:其实左右无所谓了,清楚大小就行)

分析:裸的最优二叉树→_→,妈呀,比赛的时候纠结了半天,还特么用线段树的形式写了一发,傻逼啊!

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-8)
#define inf 0x3f3f3f3f
#define ll long long int
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
const int mod = 1000000007;
const int Max = 150005;
int t,n,m;
int a[1005];
int b[1005];
struct node
{
    int v;
    node *l,*r;
};
void solve(node *root,int k)
{
    //puts("asdf");
    if(root->v==k||root==NULL)
    {
        printf("\n");
        return;
    }
    else if(k<root->v)
    {
        printf("E");
        return solve(root->l,k);
    }
    else
    {
        printf("W");
        return solve(root->r,k);
    }
}
node *Insert(node *root,int k)
{
    if(root==NULL)
    {
        root=new node;
        root->v=k;
        root->l=root->r=NULL;
        return root;
    }
    if(k<root->v)
        root->l=Insert(root->l,k);
    else
        root->r=Insert(root->r,k);
    return root;
}
node *Creat(int *w,int e)
{
    node *T=NULL;
    for(int i=0; i<n; i++)
        T=Insert(T,w[i]);
    return T;
}
int main()
{
    cin>>t;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(int i=0; i<m; i++)
            scanf("%d",&b[i]);
        //puts("ssss");
        node *root=Creat(a,n);
        //puts("ddddd");
        node *rot=NULL;
        //puts("aaaaa");
        for(int i=0;i<m;i++)
        {
            rot=root;
            //puts("dadssd");
            solve(rot,b[i]);
        }
    }
    return 0;
}


题目链接:点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: