您的位置:首页 > 其它

POJ 题目2823 Sliding Window(单调队列求定长区间最大值)

2015-09-25 18:57 429 查看
Sliding Window

Time Limit: 12000MSMemory Limit: 65536K
Total Submissions: 48701Accepted: 14078
Case Time Limit: 5000MS
Description
An array of size n ≤ 106 is given to you. There is a sliding window of size
k which is moving from the very left of the array to the very right. You can only see the
k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:

The array is
[1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1 3 -1] -3 5 3 6 7 -13
1 [3 -1 -3] 5 3 6 7 -33
1 3 [-1 -3 5] 3 6 7 -35
1 3 -1 [-3 5 3] 6 7 -35
1 3 -1 -3 [5 3 6] 7 36
1 3 -1 -3 5 [3 6 7]37
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers
n and k which are the lengths of the array and the sliding window. There are
n integers in the second line.

Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input
8 3
1 3 -1 -3 5 3 6 7

Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source
POJ Monthly--2006.04.28, Ikki

来了机房就开始睡。。睡醒来一发,

开始做过这题,用rmq做的,又用单调队列试了一发,时间比rmq省一些,内存省了不少

rmq做法:http://blog.csdn.net/yu_ch_sh/article/details/47083283

ac代码

Problem: 2823  User: kxh1995
Memory: 4048K  Time: 5282MS
Language: C++  Result: Accepted


#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 1000010
int a
,q
;
int main()
{
int n,k;
while(scanf("%d%d",&n,&k)!=EOF)
{
int i,j;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
int front,rear;
front=0;
rear=-1;
for(i=1;i<=k;i++)
{
for(;front<=rear&&a[i]<=a[q[rear]];rear--);
q[++rear]=i;
}
printf("%d",a[q[front]]);
for(j=1;i<=n;i++,j++)
{
if(front<=rear&&q[front]<=j)
front++;
for(;front<=rear&&a[i]<=a[q[rear]];rear--);
q[++rear]=i;
printf(" %d",a[q[front]]);
}
printf("\n");
front=0;
rear=-1;
for(i=1;i<=k;i++)
{
for(;front<=rear&&a[i]>=a[q[rear]];rear--);
q[++rear]=i;
}
printf("%d",a[q[front]]);
for(j=1;i<=n;i++,j++)
{
if(front<=rear&&q[front]<=j)
front++;
for(;front<=rear&&a[i]>=a[q[rear]];rear--);
q[++rear]=i;
printf(" %d",a[q[front]]);
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: