您的位置:首页 > 其它

HDU 5137 How Many Maos Does the Guanxi Worth(枚举+dijkstra) 2014ICPC 广州站现场赛

2015-09-25 17:24 495 查看


How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1196 Accepted Submission(s): 428



Problem Description

"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them
is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.



Input

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.



Output

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.



Sample Input

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0




Sample Output

50
Inf




题意:给出N个点和M条边,求去掉一个点之后是否能从点1到点N,如果能则输出最长路径,如果不能到达输出Inf。

分析:我们枚举去掉从第二个点到第N-1个点,然后对每一次求最长路径,去其中的最大值即可。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-8)
#define inf 0x3f3f3f3f
#define ll long long int
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
const int mod = 1000000007;
const int Max = 505;
int edge[Max][Max];
int s[Max];
int dist[Max];
int vis[Max][Max];
int n,m;
int low[35],dep[35];
int depth,root;
bool flag[35];
int DJ(int v0)
{
    memset(s, 0, sizeof(s));
    s[v0] = 1;
    for(int i = 1; i <= n; i++)
        dist[i] = (i==1 ? 0 : inf);
    for(int i = 1; i <= n; i++)
    {
        int x, m = inf;
        for(int j = 1; j <= n; j++) if(!s[j] && dist[j]<=m) m = dist[x=j];
        s[x]=1;
        for(int j = 1; j <= n; j++) dist[j] = min(dist[j], dist[x] + edge[x][j]);
    }
    return dist
;
}
int main()
{
    int u,v,w,cnt=1;
    while(scanf("%d%d",&n,&m)&&(m+n)!=0)
    {
        memset(dist,inf,sizeof dist);
        memset(edge,0,sizeof edge);
        memset(flag,false,sizeof flag);
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            edge[u][v]=w;
            edge[v][u]=w;
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(j==i)
                    edge[i][j]=0;
                else if(edge[i][j]==0)
                    edge[i][j]=inf;
            }
        }
        int ans=0;
        for(int i=2;i<n;i++)
        {
            ans=max(DJ(i),ans);
        }
        if(ans==inf)
            printf("Inf\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}


题目链接:点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: