您的位置:首页 > 移动开发

HDU 5119 Happy Matt Friends (DP)2014ICPC 北京站现场赛

2015-09-25 10:40 423 查看


Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others) Memory Limit: 510000/510000 K (Java/Others)

Total Submission(s): 1388 Accepted Submission(s): 554



Problem Description

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.



Input

The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.



Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.



Sample Input

2
3 2
1 2 3
3 3
1 2 3




Sample Output

Case #1: 4
Case #2: 2

HintIn the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.




题意:输入N和M,表示有N个数供你随机选择,求你选择的这些数(不能有重复的)的异或值大于等于M的方法有多少个,不选异或值就是零,选一个异或值就是本身。

分析:N最大为40,暴力法的复杂度为N!,必然不可行,考虑到N的范围比较小,而且这些数的异或值是有限的。所以想到是一道动态规划题。而异或的最大值为10^6约等于2^20,我们可以在这个范围内枚举异或,对于从第一个数取到第n个数的的结果就是d
[∑j],j为大于m的异或值,对于每一个阶段,我们可以选择异或a[i]或者不异或,对应的状态转移方程也就是a[i][j]=a[i-1][j]+a[i-1][j^a[i]]。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-8)
#define inf 0x3f3f3f3f
#define ll long long int
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
const int mod = 1000000007;
const int Max = 2021000;

int t,n,m;
int dp[45][Max];
int a[45];
ll ans;
int main()
{
    scanf("%d",&t);
    int cnt=1;
    while(t--)
    {
        ans=0;
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof dp);
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        //int Maxn=(1<<20);
        //cout<<Maxn<<endl;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=(1<<20);j++)
            {
                dp[i][j]=dp[i-1][j]+dp[i-1][j^a[i]];
            }
        }
        for(int i=m;i<=Max;i++)
        {
            ans+=dp
[i];
        }
        printf("Case #%d: %lld\n",cnt++,ans);
    }
    return 0;
}


题目链接:点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: