您的位置:首页 > 其它

HDU 2955 Robberies (01背包dp)

2015-09-24 20:41 591 查看


Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16848 Accepted Submission(s): 6217



Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


Sample Output

2
4
6


本题就是一个01背包问题,选择哪个银行抢哪个不抢,从而达到最优解

本题如果从正面求被抓的最小的概率,那么,dp数组的初始化会是一个问题,所以这道题应该从另一面求解,求解安全概率,在一定金额的情况下,取安全概率最大的,安全概率最大,则危险概率最小,初始金钱为 0 时安全概率为 1 ,其他的初始值都为0,用滚动数组dp来解答!

附上代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#define MAXN 101
#define MAXV 10001

using namespace std;

int money[MAXN];
double proba[MAXV],dp[MAXV];

int main()
{
    int test,sumv,n,i,j;
    double P;
    cin>>test;
    while(test--)
    {
        scanf("%lf %d",&P,&n);         //  被抓的概率 p    
        P=1-P;                        //   p表示安全的概率 
        sumv=0;                       //   表示各个银行的总钱数 
        for(i=0;i<n;i++)
        {
            scanf("%d %lf",&money[i],&proba[i]);        //  money  记录每个银行的钱数   proba  每个银行被抓概率 
            proba[i]=1-proba[i];             //   每个银行的安全概率 
            sumv+=money[i];                     //  记录一共有多少钱 
        }
        for(i=0;i<=sumv;i++)
            dp[i]=0;               //   金钱为  i  时的概率 ,赋初值 0  
        dp[0]=1;          //    当偷的钱为 0 时,安全概率为 1 
        for(i=0;i<n;i++)
        {                       //    n  个银行   依次判断n个银行,决定抢还是不抢 
            for(j=sumv;j>=money[i];j--)
            {                              
                dp[j]=max(dp[j],dp[j-money[i]]*proba[i]);       //  选取偷  j 元钱时安全概率最大的  即危险概率最小 
            }
        }
        
        for(i=sumv;i>=0;i--)                 //  偷的钱越多,安全概率越低,故从最大金额开始查找 
        {
            if(dp[i]-P>0.000000001)     //  当安全概率在题中给出的安全概率范围内,即大于题中的安全范围,也就是危险概率没达到上限,此时就是最大金额数 
            {
                printf("%d\n",i);   
                break;
            }
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: