您的位置:首页 > 其它

ZOJ.1597 Circular Area【两圆相交面积】 2015/09/23

2015-09-23 22:28 260 查看
Circular Area

Time Limit: 2 Seconds
Memory Limit: 65536 KB

Your task is to write a program, which, given two circles, calculates the area of their intersection with the accuracy of three digits after decimal point.

Input

In the single line of input file there are space-separated real numbers x1 y1 r1 x2 y2 r2. They represent center coordinates and radii of two circles.

Process to the end of input.

Output

The output file must contain single real number - the area.

Sample Input

20.0 30.0 15.0 40.0 30.0 30.0

Sample Output

608.366

Source: Northeastern Europe 2000, Far-Eastern Subregion

计算两圆相交面积,模板
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

double overlop_area(double x1,double y1,double r1,double x2,double y2,double r2){
double d = sqrt( (x1-x2)*(x1-x2) + (y1-y2)*(y1-y2) );
double angle1,angle2,h1,h2,s1,s2;
if( d >= r1+r2 )
return 0;
if( d <= fabs(r1-r2) )
return min( acos(-1.0)*r1*r1 , acos(-1.0)*r2*r2 );
angle1 = acos( (d*d+r1*r1-r2*r2) / (2*d*r1) );
angle2 = acos( (d*d+r2*r2-r1*r1) / (2*d*r2) );
h1 = angle1 * r1 * r1;
h2 = angle2 * r2 * r2;
s1 = r1 * r1 * cos(angle1) * sin(angle1);
s2 = r2 * r2 * cos(angle2) * sin(angle2);
return h1 + h2 - (s1+s2);
}

int main(){
double x1,x2,r1,y1,y2,r2;
while( ~scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&r1,&x2,&y2,&r2) ){
printf("%.3lf\n",overlop_area(x1,y1,r1,x2,y2,r2));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: