您的位置:首页 > 其它

HDU 2119--Matrix【二分图 && 最小点数覆盖】

2015-09-23 16:58 627 查看

Matrix

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2239 Accepted Submission(s): 996



Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.


Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.

The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.



Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.



Sample Input
3 3 
0 0 0
1 0 1
0 1 0
0




Sample Output
2


题意:

给你一个N*M的矩阵,矩阵里面有一些位置是1。每次操作可以划去同一行或者同一列的1,问你最少需要几次操作。



解析:

最小点数覆盖的水题,没啥好说的。根据矩阵建好关系图,直接匈牙利就行了。



#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 550
using namespace std;
int map[maxn][maxn];
int used[maxn];
int link[maxn];
int n, m;

void init(){
    memset(map, 0, sizeof(map));
}

void getmap(){

    for(int i = 1; i <= n; ++i)
    for(int j = 1; j <= m; ++j){
        scanf("%d", &map[i][j]);
    }
}

bool dfs(int x){
    for(int i = 1; i <= m; ++i){
        if(map[x][i] && !used[i]){
            used[i] = 1;
            if(link[i] == -1 || dfs(link[i])){
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int hungary(){
    int ans = 0;
    memset(link, -1, sizeof(link));
    for(int i = 1; i <= n; ++i){
        memset(used, 0, sizeof(used));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main (){
    while(scanf("%d", &n), n){
        scanf("%d", &m);
        init();
        getmap();
        int sum = hungary();
        printf("%d\n", sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: