您的位置:首页 > 理论基础 > 计算机网络

Jesus Is Here(区域赛网络赛选拔)

2015-09-22 20:07 344 查看


Jesus Is Here

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 65535/102400 K (Java/Others)

Total Submission(s): 0 Accepted Submission(s): 0



Problem Description

I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?

``But Jesus is here!" the priest intoned. ``Show me your messages."

Fine, the first message is s1=‘‘c" and
the second one is s2=‘‘ff".

The i-th
message is si=si−2+si−1 afterwards.
Let me give you some examples.

s3=‘‘cff", s4=‘‘ffcff" and s5=‘‘cffffcff".

``I found the i-th
message's utterly charming," Jesus said.

``Look at the fifth message". s5=‘‘cffffcff" and
two ‘‘cff" appear
in it.

The distance between the first ‘‘cff" and
the second one we said, is 5.

``You are right, my friend," Jesus said. ``Love is patient, love is kind.

It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.

Love does not delight in evil but rejoices with the truth.

It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different ‘‘cff" as
substrings of the message.

Input

An integer T (1≤T≤100),
indicating there are T test
cases.

Following T lines,
each line contain an integer n (3≤n≤201314),
as the identifier of message.

Output

The output contains exactly T lines.

Each line contains an integer equaling to:

∑i<j:sn[i..i+2]=sn[j..j+2]=‘‘cff"(j−i) mod 530600414,

where sn as
a string corresponding to the n-th
message.

Sample Input

9
5
6
7
8
113
1205
199312
199401
201314


Sample Output

Case #1: 5
Case #2: 16
Case #3: 88
Case #4: 352
Case #5: 318505405
Case #6: 391786781
Case #7: 133875314
Case #8: 83347132
Case #9: 16520782
//I have given up the treatment-_-||
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<cmath>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
#define inf 0x3f3f3f3f
#define max1(a,b) (a)>(b)?(a):(b)
#define min1(a,b) (a)<(b)?(a):(b)
#define LL  __int64
#define ll  long long
#define lson  l,m,rt<<1
#define rson  m+1,r,rt<<1|1
#define eps  1e-12
using namespace std;
const int  N=250005;
const int mod=10000000007;
long long h[201400][5];
int main()
{
//   h[4]={5,0,0,5,1};
//   h[5]={11,5,5,8,2};
h[4][0]=5;
h[4][1]=0;
h[4][2]=0;
h[4][3]=5;
h[4][4]=1;
h[5][0]=11;
h[5][1]=5;
h[5][2]=5;
h[5][3]=8;
h[5][4]=2;
for(int i=6;i<=201315;i++)
{
h[i][4]=(h[i-1][4]%530600414+h[i-2][4]%530600414)%530600414;
h[i][3]=(h[i-1][3]%530600414+h[i-2][3]%530600414)%530600414;
h[i][2]=((h[i-1][4]%530600414)*(h[i-2][1]%530600414)%530600414+(h[i-2][4]%530600414)*(h[i-1][0]%530600414)%530600414+h[i-1][2]%530600414+h[i-2][2]%530600414)%530600414;
//h[i][2]%=530600414;
h[i][0]=(((h[i-1][4]%530600414)*(h[i-2][3]%530600414))%530600414+h[i-2][0]%530600414+h[i-1][0]%530600414)%530600414;
h[i][1]=(((h[i-2][4]%530600414)*(h[i-1][3]%530600414))%530600414+h[i-1][1]%530600414+h[i-2][1]%530600414)%530600414;
}
int T,n,f=1;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
printf("Case #%d: %lld\n",f++,h
[2]);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: