您的位置:首页 > 其它

ZOJ.1797 Least Common Multiple【最小公倍数,水】 2015/09/22

2015-09-22 17:08 357 查看
Least Common Multiple

Time Limit: 2 Seconds
Memory Limit: 65536 KB

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers
in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1

Sample Output

105

10296

Source: East Central North America 2003, Practice

求n个数的最小公倍数,水~
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int gcd(int a,int b){
return b?gcd(b,a%b):a;
}

int lcm(int a,int b){
int ret = gcd(a,b);
return a/ret*b;
}

int main(){
int t,n,i,ret,a;
cin>>t;
while(t--){
scanf("%d",&n);
ret = 1;
while(n--){
scanf("%d",&a);
ret = lcm(ret,a);
}
printf("%d\n",ret);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: