您的位置:首页 > 运维架构

hdu 4349 Xiao Ming's Hope(C(n,m)的奇偶性)

2015-09-22 15:01 197 查看
题目:http://acm.hdu.edu.cn/showproblem.php?pid=4349

大意:给出n,求解C(n,0),C(n,1),C(n,2)……C(n,n)中有多少个奇数。

C(n,m)%p 由lucas定理可知C(n,m)%2=C(n%2,m%2)*[C(n/2,m/2)%2],分解下去,对于C(a,b) (a=0 or a=1; b=0 or b=1)。C(0,1)=0; C(0,0)=1; C(1,0)=C((1,1)=1; 可以看出,变成了n,m的二进制形式比较:如果a&b=b,那么它是奇数,否则是偶数。 但这里的数据级是1e8。继续探索发现。。。

满足奇数:n为0的地方,m必须为0,n为1的地方,m随便(二进制),所以结果应该是



n1表示n的二进制形式中1的个数。

Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1836 Accepted Submission(s): 1222



Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing
classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?".
Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1,
there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In
order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want
to let her down. Can you help him?


Input
Each line contains a integer n(1<=n<=108)


Output
A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).


Sample Input
1
2
11




Sample Output
2
2
8


#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int n;
    while(cin>>n){
        int sum=0;
        while(n){
            sum+=n%2;
            n>>=1;
        }
        printf("%d\n",1<<sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: