您的位置:首页 > 其它

HDOJ 题目1078 FatMouse and Cheese(记忆化搜索+DP)

2015-09-22 11:02 405 查看

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6627 Accepted Submission(s): 2725



[align=left]Problem Description[/align]
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100
blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

[align=left]Input[/align]
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.

[align=left]Output[/align]
For each test case output in a line the single integer giving the number of blocks of cheese collected.

[align=left]Sample Input[/align]

3 1
1 2 5
10 11 6
12 12 7
-1 -1


[align=left]Sample Output[/align]

37


[align=left]Source[/align]
Zhejiang University Training Contest 2001

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1080 1074 1158 1227 1502
ac代码

#include<stdio.h>
#include<string.h>
#define LL __int64
int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
int n,k;
LL map[1010][1010],dp[1010][1010];
int jud(int x,int y)
{
if(x>=1&&x<=n&&y>=1&&y<=n)
return 1;
return 0;
}
LL dfs(int x,int y)
{
int i,j;
int temp=0;
if(dp[x][y])
return dp[x][y];
for(i=0;i<4;i++)
{
for(j=1;j<=k;j++)
{

int xx=x+dir[i][0]*j;
int yy=y+dir[i][1]*j;
if(jud(xx,yy)&&map[xx][yy]>map[x][y])
{
LL tmp=dfs(xx,yy);
if(temp<tmp)
temp=tmp;
}
}
}
dp[x][y]=temp+map[x][y];
return dp[x][y];
}
int main()
{
//int n,k;
while(scanf("%d%d",&n,&k)!=EOF,n!=-1||k!=-1)
{
int i,j;
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
scanf("%I64dd",&map[i][j]);
}
memset(dp,0,sizeof(dp));
printf("%I64d\n",dfs(1,1));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: